少し分からない部分があります。SMB 1.0/CIFSクライアントをオンにしても他のSMBサーバーがSMB2/SMB3をサポートしていればネゴシエートの結果SMB3.xで接続するはずですが、何を設定するとエラーコード:0x80070035 ネットワークパスが見つかりませんとなるのでしょう?
SMB 1.0/CIFSサーバー・クライントの有効化は脆弱性を付いた攻撃に対して安全性を保つことが出来なくなるだけで通信エラーを引き起こす原因にはなりません。
\{HOSTNAME}{sharename}にアクセス出来ませんはもっとプリミティブな部分に対して起こっている障害が原因のはずです。少しそのエラーを説明してください。