Не работает Модель данных в Excel 2013/2016

Анонимные
2017-10-31T10:08:40+00:00

Добрый день!

Перестала корректно работать модель данных в Excel 2013 Стандартный (на работе) и 2016 Профессиональный (дома), а также 2016 на работе у друга (в другой организации).

Книга в которой раньше отлично работала модель данных теперь в списке полей сводной таблица в  разделе "Значения" вместо списка добавленных туда для расчета Полей сводной таблицы показывает одно пустое поле (см. прикрепленный рисунок).

Здесь должен быть список полей добавленных в область "Значения". (сделать скриншот того как должно быть не представляется возможным, так как ни на одном компьютере к которому я имею доступ корректно не работает)

Но самое главное это при попытке создать в новой книге модель данных она совершенно не работает.

Пример: создаем 2 таблицы (именно форматированные как таблица Excel): Цвета и Смеси. В Таблице Цвета следующие поля: Код, Краска. В таблице Смеси поля: НомерСмеси, НазваниеСмеси, НомерКраски.

(в смесь 1 входят краски: 1,6,3;

в смесь 3 входят краски: 7, 9, 8, 4;

в смесь 4 входят краски: 1, 2, 3;

в смесь 5 входят краски: 6, 9;

в смесь 6 входят краски: 4;

в смесь 7 входят краски: 5, 6, 4;

в смесь 9 входят краски: 7, 1, 2;

в смесь 10 входят краски: 3, 8;)

Добавляем обе эти таблицы в модель данных (на вкладке данные). Потом задаем отношения (там же на вкладке данные): НомерКраски (из таблицы Смеси) - Код (из таблицы Цвета).

Затем строим сводную таблицу на основе модели данных. и добавляем из таблицы Смеси поле НазваниеСмеси в область Строки. Далее туда же в область Строки добавляем поле Краска из таблицы Цвета.

Ни и как Вы думаете что у нас получилось?! Наверно как и прежде под каждой строкой НазваниеСмеси будут перечислены только те Краски, которые в нее входят?! (Например в сводной таблице под словом "Смесь 1" будут перечислены только: Белая, Красная, Фуксия.) Нет!!!! Перечислены все краски для каждой смеси, как при полном объединении!!! при этом если поле Краска из таблицы Цвета перетащить в область Значения то Excel вообще говорит что "Могут потребоваться связи между таблицами" (отмечено красной стрелкой на рисунке), хотя как Вы помните связи мы уже создали!!! (см. изображения.)

Такое началось примерно 2-3 недели назад после очередных выходных (возможно какое-то обновление прилетело?! (от 03.10 или 12.10?))

Майкрософт меня всячески игнорит.  Без этой фичи мы работать нормально не можем - ни один отчет не выгрузить в модель данных из БД.

Ссылка на тестовый файл:

Файл

Ссылка на скриншоты:

Изображение 1

Изображение 2

Изображение 3

Спасибо за внимание!

Microsoft 365 и Office | Excel | Для дома | Windows
Microsoft 365 и Office | Excel | Для дома | Windows

Семейство программного обеспечения Майкрософт для работы с электронными таблицами, оснащенное инструментами для анализа, построения диаграмм и обмена данными.

Заблокированный вопрос. Этот вопрос был перенесен из сообщества службы поддержки Майкрософт. Вы можете проголосовать о его полезности, но не можете добавлять комментарии или ответы, а также подписаться на этот вопрос.

Комментариев: 0 Без комментариев

Ответы: 37

Сортировать по: Наиболее полезные
  1. Анонимные
    2017-11-01T18:44:50+00:00

    Не помогло.

    Две таблицы на разных листах (описание в топовом и в файле примера). Потом вкладка Данные - Подключения - Стрелка вниз на кнопке Добавить - Добавить в модель данных. Выбираем первую таблицу, затем также вторую. Затем вкладка Данные - Отношения - Создать. (Таблица: Смеси, Столбец (чужой): НомерКраски. Связанная таблица: Цвета, Связанный столбец (первичный ключ): Код).

    Затем: На вкладке Вставка - Сводная таблица - переключатель в Использовать внешний источник данных - кнопка выбрать подключение - вкладка таблица - Модель данных.

    Вставляем сводную на третий лист. Далее добавляем в область Строки поле НазваниеСмеси из таблицы Смеси, И туда же в область Строки: Краска из таблицы Цвета.

    Результат как на скриншоте в топовом...

    Уважаемый Жук, если Вы выполняете эти же шаги и у Вас другой результат, пожалуйста киньте скриншот.

    Этот ответ помог вам?

    Комментариев: 0 Без комментариев
  2. Анонимные
    2017-11-01T18:00:23+00:00

    Не знаю местных правил. Сорри. Менял - добавлял то что просил пользователь Жук в топовом чтоб было все в одном месте. Исправлюсь. По проблеме - сейчас снес 2016 офис, накатываю 2013 стандартный без обновлений. Попробую на нем. О результате сразу отпишусь.

    Этот ответ помог вам?

    Комментариев: 0 Без комментариев
  3. Анонимные
    2017-11-01T17:57:55+00:00

    Уважаемый Жук, извиняюсь что был резок, просто уже очень долго бьюсь с этой ситуацией.

    Вы говорите что в построенной вами сводной таблице все хорошо, и я вижу это на вашем скриншоте  (последнем). У меня только вопрос, она построена по тому же принципу: 2 таблицы на разных листах объединены в модель данных и на основе модели построена сводная? Если да, и если Вас это не затруднит, не могли бы Вы поле Цвета (судя по заголовку на вашем последнем скриншоте у Вас это поле цвета называется) убрать из области Значения, а в область Строки добавить названия этих цветов (из таблицы цвета. В моем примере это поле Краска, у Вас наверно это поле Цвета, но не уверен, не вижу ваших таблиц двух)) . Чтобы для каждой смеси выводилось не количество входящих в нее цветов, а перечислялись названия этих цветов. Как на скриншоте ниже. И выложить скриншот получившегося результата.

    Спасибо за потраченное на эту проблему время.

    Этот ответ помог вам?

    Комментариев: 0 Без комментариев
  4. Анонимные
    2017-11-01T16:20:40+00:00

    Может еще какие-нибудь пользователи включатся в обсуждение? Сотрудники Майкрософт ау, Вы тут есть? может вы быстрее в суть проблемы въедете.....

    Добрый день Сергей_Gard

    Я конечно могу включиться в обсуждение, но у меня одно условие:

    Не нужно менять показания каждые 2-3 часа (рис. 1)

    Если у Вас пользователь Жук попросил скриншот, то (ИМХО) нужный скриншот можно разместить в ответе, но не менять ТОПОВОЕ сообщение.

    Рис. 1

    Этот ответ помог вам?

    Комментариев: 0 Без комментариев
  5. Анонимные
    2017-11-01T16:10:09+00:00
    1. Для какой цели вы скриншоты не вставили в свой основной вопрос:

    1. Жесть это то, что вы не можете внятно рассказать о вашей проблеме, потому что например у меня получается результат:

    в связи с чем вам и задаются уточняющие вопросы, так же ответьте, почему в Смеси № 1 три краски, а по вашим данным получается четыре.

    В довершении, почему у меня в сводной таблице, результатом получается:

    Этот ответ помог вам?

    Комментариев: 0 Без комментариев