Odoo envoi SMTP erreur 5.7.57 Client not authenticated to send mail. Error: 451 4.7.0 Temporary server error

EdithSirois-7354 0 Points de réputation
2024-11-16T14:55:32.5233333+00:00

Lorsque j'essaie de configurer dans Odoo l'utilisation de Microsoft Outlook pour les courriels, problème d'accès d'envoi SMTP mais capable de me brancher à l'application créer dans Entra

erreur b'5.7.57 Client not authenticated to send mail. Error: 451 4.7.0 Temporary server error

Pourtant l'envoi de SMTP est activé pour mon tenant et pour mon utilisateur.

Exchange Online
Exchange Online

Un service basé sur le cloud inclus dans Microsoft 365, offrant des fonctionnalités de messagerie et de collaboration évolutives avec une gestion simplifiée et des mises à jour automatiques.

Azure
Azure

Plateforme et infrastructure de cloud computing pour la génération, le déploiement et la gestion d’applications et de services à travers un réseau mondial de centres de données gérés par Microsoft.

Centre communautaire | Discuter du site Q&A | Prise en main de Q&A
0 commentaires Aucun commentaire

12 réponses

  1. Dranguet Nans 0 Points de réputation
    2024-12-06T21:53:17.1333333+00:00

    Visiblement Odoo a besoin des autorisations SMTP.Send et IMAP.AccessAsUser.All

    https://www.odoo.com/fr_FR/documentation/17.0/applications/general/email_communication/azure_oauth.html?

    Cette réponse a-t-elle été utile ?


  2. EdithSirois-7354 0 Points de réputation
    2024-12-04T18:47:10.2066667+00:00

    Dans Odoo ça fonctionne si je rentre l'authenitification avec nom d'utilisateur et mot de passe.

    Si je rentre Authentification OAuth Outlook je me connecte à mon compte car il indique Outlook Token Valid mais ensuite il me met en le message d'erreur

    Invalid Operation

    The server refused the sender address (******@sadcshawinigan.ca) with error b'5.7.57 Client not authenticated to send mail. Error: 451 4.7.0 Temporary server error. Please try again later. PRX5 [CH2PR05CA0024.namprd05.prod.outlook.com 2024-12-04T18:46:28.458Z 08DD127E30A5A5A3]'

    Cette réponse a-t-elle été utile ?

    0 commentaires Aucun commentaire

  3. Vincent de Munico 0 Points de réputation
    2024-12-04T17:16:22.9933333+00:00

    De ce que je peux lire il faudrait désactiver l'accès conditionnel :

    https://www.linkedin.com/pulse/troubleshooting-error-authentication-unsuccessful-365-hossain-bkskc/

    Seulement pour faire ceci, il faut désormais Entra version Premium. Vous confirmez ?

    Cette réponse a-t-elle été utile ?


  4. Dranguet Nans 0 Points de réputation
    2024-12-03T22:07:11.1166667+00:00

    Avez vous les différents logs ?

    Cette réponse a-t-elle été utile ?

    0 commentaires Aucun commentaire

  5. EdithSirois-7354 0 Points de réputation
    2024-12-03T21:40:21.3566667+00:00

    Toutes ces étapes sont faites depuis fort longtemps et ça ne fonctionne pas plus

    1. Permission d'envoi d'e-mails :
      • L'application doit avoir la permission SMTP.Send. ---> OUI
      • Cette permission doit être granted/admin consented pour le tenant. ---> OUI
    2. Authentification moderne :
      • Si vous utilisez une application, vous devez utiliser l'authentification OAuth2 avec un jeton valide pour l'envoi de courriels. ---> OUI
      • Les configurations nécessitent souvent un ID client, un secret client et l’utilisation d’un jeton OAuth pour s’authentifier. ---> OUI

    Cette réponse a-t-elle été utile ?

    0 commentaires Aucun commentaire

Votre réponse

Les réponses peuvent être marquées comme « Acceptées » par l’auteur de la question et « Recommandées » par les modérateurs, ce qui aide les utilisateurs à savoir que la réponse a résolu le problème de l’auteur.