Odoo envoi SMTP erreur 5.7.57 Client not authenticated to send mail. Error: 451 4.7.0 Temporary server error

EdithSirois-7354 0 Points de réputation
2024-11-16T14:55:32.5233333+00:00

Lorsque j'essaie de configurer dans Odoo l'utilisation de Microsoft Outlook pour les courriels, problème d'accès d'envoi SMTP mais capable de me brancher à l'application créer dans Entra

erreur b'5.7.57 Client not authenticated to send mail. Error: 451 4.7.0 Temporary server error

Pourtant l'envoi de SMTP est activé pour mon tenant et pour mon utilisateur.

Exchange Online
Exchange Online

Un service basé sur le cloud inclus dans Microsoft 365, offrant des fonctionnalités de messagerie et de collaboration évolutives avec une gestion simplifiée et des mises à jour automatiques.

Azure
Azure

Plateforme et infrastructure de cloud computing pour la génération, le déploiement et la gestion d’applications et de services à travers un réseau mondial de centres de données gérés par Microsoft.

Centre communautaire | Discuter du site Q&A | Prise en main de Q&A
0 commentaires Aucun commentaire

12 réponses

Trier par : Le plus utile
  1. EdithSirois-7354 0 Points de réputation
    2024-12-03T20:56:08.9366667+00:00

    Oui SMTP authentifié est activé

    Cette réponse vous a-t-elle été utile?


  2. Dranguet Nans 0 Points de réputation
    2024-12-03T20:53:39.81+00:00

    Dans le Centre d'administration Microsoft, va dans Utilisateurs > Utilisateurs actifs. Sélectionne l'utilisateur, puis clique sur Mail. Dans la section Applications de messagerie, assure-toi que l'option Authentification SMTP vérifiée est activée

    essai en navigation privé pour enregistrer a nouveau le jeton

    si ça ne marche toujours pas, envoi les logs Outlook et les logs authent/login côté azure/exo

    Cette réponse vous a-t-elle été utile?

    0 commentaires Aucun commentaire

  3. EdithSirois-7354 0 Points de réputation
    2024-12-03T20:30:05.28+00:00

    J'ai enlevé le MFA pour mon utilisateur et ça ne fonctionne pas plus.

    Dans Odoo il m'indique que mon jeton Outlook est valide donc ma connexion se fait

    Cette réponse vous a-t-elle été utile?

    0 commentaires Aucun commentaire

  4. Dranguet Nans 0 Points de réputation
    2024-12-01T18:30:11.7733333+00:00

    Si tu utilises MFA, il peut être nécessaire de créer une politique d'accès conditionnel pour exclure l'utilisateur qui enregistre le jeton dans Odoo

    Cette réponse vous a-t-elle été utile?

    0 commentaires Aucun commentaire

  5. Dranguet Nans 0 Points de réputation
    2024-11-18T15:33:43.08+00:00

    les paramètres SMTP sont comme ceci ? :

    Serveur SMTP : smtp.office365.com

    Port : 587

    Méthode de chiffrement : STARTTLS

    MFA sur le user ?

    Cette réponse vous a-t-elle été utile?


Votre réponse

Les réponses peuvent être marquées comme « Acceptées » par l’auteur(e) de la question et « Recommandées » par les modérateurs, ce qui aide les utilisateurs à savoir que la réponse a résolu le problème de l’auteur(e).