MacOS Sequoia 15.5與 Outlook for Mac 16.98 16.99兩版本都出現 OAuth 2.0 Token 快取與重新整理流程的檢核 失敗狀況 + memory leak ?

HC Yu 20 信譽點數
2025-07-19T03:42:51.53+00:00

Hi there,

我目前使用Macbook 都更新到最新版 macOS Sequoia 15.5,6月透過 Apple store 更新 Microsoft 365訂閱版 Outlook (版本16.98.1 25061520)後,舊版 outlook 直接閃退,包括手上 M1 pro Mackbook pro 與 M4 Macbook air都一樣,於是我改用新版outlook,可行。

再來,Outlook 透過 Exchange 收發公司電子郵件,每個月需要更新密碼,2025年7月更新密碼後,新版 outlook 就無法登入連線錯誤。公司 IT 協助後也無法登入。但是網頁版信箱可以登入使用。結果我又轉回舊版 outlook,竟然可以登入正常使用。M1 Pro 與 M4 Macbook 症狀一模一樣。

另外 2025年7/16日更新 outlook for mac 到16.99版,更換公司信箱密碼後,又出現無法登入現象。Outlook 舊版則可以登入。

重要的是,16.98與 16.99版本,新版 outlook 對記憶體佔用相當明顯,感覺出現 memory leak 現象。16.98 與 16.99兩版本使用6小時候都會佔用超過 4GB 記憶體。16.98版本更高到12-13GB。

先前詢問過 Microsoft 社群,專家回覆如下: 但不到兩小時這個對話就被移除了 😭😭

macOS Sequoia(15.5)加強了對 OAuth 2.0 Token 快取與重新整理流程的檢核,若應用程式未更新以配合新的安全標準,就可能在「第一次授權後」或「已儲存憑證更新」時發生失敗。新版 Outlook for Mac 採用新的現代認證架構,顯然在與 Sequoia 15.5 的互動中出現了相容性回歸(regression),導致「Token 刷新」或「憑證快取」失敗。

目前舊版 Outlook 依舊會持續一段時間,如果您的企業需要在客戶端登入連線。請繼續使用它,也有不少的用戶嘗試透過手動配置來完成這個同步(手動配置,例如IMAP。POP3則不需要藉助OAuth 2.0這類現代驗證的方式)但取決於公司的郵件提供者是否可以支援這類協議的配置。

我再附上透過 outlook 日誌的節錄分享在我電腦使用上的問題:

Outlook 記憶體佔用異常,並從日誌中找到以下訊息,顯示在啟動時,用於身分驗證的 OneAuth 模組無法正確處理 zh-TW 語言代碼。這可能是一個相容性回歸問題。

07/19/2025... OUTLOOK ... OneAuth log {"Message":"[MSAL:0001]\tERROR \t...Language code 'zh-TW' is not supported, fall back to default of 'en'","IsError":true}

請問微軟的其他專家,能否協助讓 MacOS 用戶可以安心使用 Outlook ? 謝謝

Outlook | MacOS | 新版 Mac 版 Outlook | 家用版
0 則留言 沒有留言

由問題作者接受的回答
Victor1-V 13,045 信譽點數 Microsoft 外部員工 仲裁者
2025-07-24T10:00:23.99+00:00

此回复已自动翻译。因此,可能存在语法错误或奇怪的表达。

Dear HC Yu,

您好!感谢您在 Microsoft Q&A 论坛发帖。我们很高兴为您提供帮助。

我了解到您在使用 macOS Sequoia 15.5 上的新版 Outlook for Mac (版本 16.98.1 和 16.99) 时遇到了严重的困扰,特别是每月更新 Exchange 帐户密码后出现的登录失败问题以及严重的内存占用/泄漏。您详细的描述和日志片段非常有帮助;它们表明新版 Outlook 的现代身份验证与 macOS Sequoia 增强的 OAuth 2.0 验证之间存在兼容性挑战,同时还可能存在与内存使用和 OneAuth 模块中 zh-TW 语言代码相关的潜在回归问题。

鉴于您在多台 M1 Pro 和 M4 MacBook 上描述的症状以及您提供的具体日志条目,这确实指向一个深层次的兼容性和性能问题,很可能需要 Microsoft 工程团队提供官方修复。

以下是根据您的详细反馈提供的一些步骤和信息:

1, 继续使用旧版 Outlook (当前临时解决方案): 

正如您所发现的,旧版 Outlook for Mac 似乎可以避免这些问题。目前,我们建议您继续使用旧版 Outlook,以确保您可以可靠地访问您的公司电子邮件。这与您之前收到的关于旧版 Outlook 将在新的身份验证架构完善期间继续运行的信息一致。 

2, 清除 Outlook 凭据和缓存 (针对新版 Outlook): 

有时,损坏的身份验证令牌可能会持续存在。您可以尝试清除 Mac 上存储的 Outlook 凭据,这可能有助于新版 Outlook 尝试重新进行身份验证。  

  1. 从钥匙串访问中删除 Outlook 的缓存凭据:  a. 完全关闭新版 Outlook。   b. 前往 Finder > 前往 > 应用程序 > 实用工具 > 钥匙串访问。   c. 在钥匙串访问中,搜索“Office”、“Outlook”、“Exchange”或“Microsoft”条目。  d. 删除与您的 Outlook Exchange 帐户密码或身份验证令牌相关的任何条目(例如,“Microsoft Office Identities Cache 2”、“Microsoft Office Identities Settings 2”)。请注意不要删除其他不相关的条目。  e. 重新启动您的 Mac。   f. 打开新版 Outlook 并尝试再次设置您的帐户。 
  2. 清除 Outlook 缓存:  a. 关闭新版 Outlook。   b. 前往 Finder > 前往 > 前往文件夹...  c.输入 /Users/admin/Library/Containers/com.microsoft.Outlook/Data/Library/Caches/ 并按下 Enter.   d. 将此文件夹的内容移至废纸篓(暂时不要清空废纸篓) e.输入 /Users/admin/Library/Containers/com.microsoft.Outlook/Data/Library/Application Support/Microsoft/Office/ 并按下 Enter.  f. 将此文件夹内的 Outlook 文件夹移至废纸篓(暂时不要清空废纸篓)。   g. 重新启动您的 Mac。   h. 打开新版 Outlook 并尝试重新配置您的帐户。如果问题仍然存在,您可以从废纸篓中恢复项目。 

3, 检查进一步的更新: 

尽管您使用的是 16.99 版本,但 Microsoft 会持续发布更新。请务必通过 App Store 或在 Outlook 中前往帮助 > 检查更新,确保您始终使用最新版本。新的更新可能包含针对已知兼容性或性能问题的修复。 

4, 语言设置检查: 

日志条目“Language code 'zh-tw' is not supported, fall back to default of 'en'”非常具体。虽然这可能是一个更深层问题的一个症状,但您可以尝试暂时将 macOS 系统语言偏好设置更改为 en-US,看看是否可以绕过此特定错误,然后重新测试新版 Outlook 的登录和内存使用情况。  

前往 系统设置 > 通用 > 语言与地区。 

将“英语 (美国)”拖到您的首选语言列表的顶部。 

重新启动您的 Mac,然后尝试新版 Outlook。请记住,如果这不能解决问题,请恢复您的语言设置。 

5, 直接向 Microsoft 提供反馈: 

由于这似乎是一个影响核心功能(身份验证)和性能(内存泄漏)的错误,并且发生在最新的 macOS 上,因此确保其得到解决的最有效方法是通过新版 Outlook for Mac 的应用内反馈机制直接报告。  

  1. 在新版 Outlook 中,前往帮助 > 联系支持或提供反馈。这允许 Microsoft 产品团队直接从您的机器收集诊断数据。请务必提及具体的 macOS 版本、Outlook 版本(16.98.1、16.99)、每月密码更改的触发因素,尤其是内存消耗和 zh-TW 日志条目。您甚至可以将您详细描述的部分内容粘贴到那里。 

我们非常感谢您花费时间处理此问题并提供了如此详尽的信息。在我们的工程团队努力解决这些兼容性挑战时,您的耐心和配合将受到高度赞赏。

如果您需要进一步的帮助,或在尝试上述建议后有任何更新,请随时回帖告知。我们期待您的回复。

此致,

Victor Vu | Microsoft Q&A 支持专家

此回答有幫助嗎?

有 1 人認為此回答有所幫助。

0 個其他答案

排序依據: 最實用

您的回答

答案可由問題作者標示為「已接受」,而由仲裁者標示為「推薦」,這可協助使用者知道答案解決了作者的問題。