OpenSearch 节点在小版本升级后无法启动并报错 OutOfMemoryError,该如何调整 jvm.options?

Heung Bin 80 信誉分
2026-09-21T08:14:09.8733333+00:00

我们对于 OpenSearch 节点在小版本升级后无法启动的情况有一些疑问,系统日志不断显示 java.lang.OutOfMemoryError: Java heap space。目前要联系到真人技术人员似乎是不可能的。支持中心表示我们无法针对目前遇到的问题购买服务或开启请求,而当我们尝试自行解决时,却卡在不知道该如何调整 jvm.options 里的 JVM 参数。如果您能提供任何建议,我们将不胜感激。

Windows 商业版 | Windows 365 商业版
0 个注释 无注释

问题作者接受的答案
VPHAN 44,940 信誉分 独立顾问
2026-09-21T08:51:01.4566667+00:00

嗨**,香彬,**

你可以通过找到通常位于 /etc/opensearch/ 目录中的 jvm.options 文件,调整初始堆大小参数(-Xms)和最大堆大小参数(-Xmx)来解决这个问题。你必须增加这些标志所附加的内存值,并严格确保它们完全匹配,比如输入 -Xms12g 和 -Xmx12g。保持最小和最大堆相同,可以防止 JVM 不断暂停你的节点以动态调整内存大小。

调整这些参数时,必须遵守规则:服务器物理内存的分配量不超过50%。OpenSearch大量依赖底层操作系统的文件系统缓存来执行快速搜索。如果分配给JVM的内存过多,操作系统将没有缓存内存,导致严重性能下降。确保新的相同堆值占用不超过物理服务器总内存的一半,最终数值不超过32GB以下,节点才能成功启动。

希望这个回答能给你带来有用的信息。如果有帮助,请点击“接受答案”。如果你有任何问题,欢迎留言。

维凡

此答案是否有帮助?

1 个人认为此答案很有帮助。
0 个注释 无注释

0 个其他答案

排序依据: 非常有帮助

你的答案

提问者可以将答案标记为“已接受”,审查方可以将答案标记为“已推荐”,这有助于用户了解答案是否解决了提问者的问题。