如何解决组织域中文域名的Punycode格式问题

Rui max 5 信誉分
2026-04-10T11:49:13.6033333+00:00

邮箱域名Punycode格式问题
我拥有一个中文域名福瑞控.com,而成功添加域后却是xn--izuy58a50d.com
我想将[版主说明:个人信息已删除]@xn--izuy58a50d.com更改为[版主说明:个人信息已删除]@福瑞控.com,请问如何解决?


* 移动自 [Microsoft 365 和 Office › 其他]

Exchange Online
Exchange Online

Microsoft 365 中包含的一款云端服务,具有可扩展的消息传递和协作功能,实现了简化管理和自动更新。


2 个答案

排序依据: 非常有帮助
  1. Caozhi Li 7,535 信誉分 志愿者审查方
    2026-04-10T15:23:46.7366667+00:00

    简单地说,很遗憾,根据现行 RFC 规范和 Exchange 对此的支持情况,我认为这是不可能的。


    如果你对这背后的技术原理感兴趣,请往下看:

    首先,在 RFC 5321 (Simple Mail Transfer Protocol) #2.3.5 节,原文指出:

    …These components ("labels" in DNS terminology, RFC 1035) are restricted for SMTP purposes to consist of a sequence of letters, digits, and hyphens drawn from the ASCII character set.

    ……这些组件(在 DNS 术语中称为”标签”,参见 RFC 1035)在 SMTP 用途下被限制为仅由来自 ASCII 字符集的字母、数字和连字符构成的序列。

    即,在最初的 SMTP 规范中,@ 符号后的主机名部分被强制限制为 ASCII 字符。在此之后,包括 RFC 6530、RFC 6531、RFC 6532 和 RFC 6533 在内的一系列 RFC 标准规定了该机制和协议的扩展,使得电子邮箱地址可以完整支持 Unicode 编码(也叫做 Email Address Internationalization,EAI)。

    然而,对 EAI 的支持极大程度上取决于邮局服务器;同一个邮局服务器可能同时支持向 EAI 地址发送邮件、接收来自 EAI 地址的邮件,却不支持托管 EAI 邮箱地址。

    Support of EAI is largely dependent on the email server. For example, an email server might support sending emails to an address using EAI; however, the same email server doesn't have to support hosting EAI email addresses.

    ——Email Address Internationalization (EAI) - Globalization | Microsoft Learn

    在 2017 年末,Exchange 团队 宣布了对于 EAI 的支持;然而,他们当时便提到,他们尚未支持添加 EAI 别名,且该功能正在评估中。

    But please note that this new release will not support adding EAI addresses for Office 365 users, or IDN domains for Office 365 organizations. We will continue to evaluate these features as the standards are more widely adopted.

    2020 年末,由 ICANN 资助的 Universal Acceptance Steering Group(UASG,普遍适用性指导小组)对电子邮箱软件和服务对 EAI 的支持情况进行了评估,并发布了报告 《Evaluation of EAI Support in Email Software and Services Report (UASG030)》(PDF)。

    ICANN 亚太区技术参与总监 Champika Wijayatunga 于 2021 年春季在 ICANN 第 70 次线上虚拟公开会议上作的 Email Address Internationalization 报告中的一张截图,其中将 EAI 的支持等级划分为三个等级。

    其中,对于 EAI 的支持被划分为三个等级:

    • 完全不支持:只支持 ASCII 字符
    • 一级(也叫做 L1 或 P1):可以通过 EAI 地址交换邮件,但不支持用 UTF-8 创建邮箱别名和域名地址
    • 二级(也叫做 L2 或 P2):在一级的基础上,支持了创建 EAI 电子邮箱地址

    在《UASG030》中,Microsoft Exchange Server 被明确标记为 L1 —— 仅支持接收和路由,不支持创建邮箱地址。

    MS Exchange Server (hosted)
    Hosted Exchange server is part of Microsoft’s Office 365 suite. We created an O365 account and configured it to handle one of our IDN domains. We found it is Phase 1 but not Phase 2 EAI-ready. All addresses handled by hosted Exchange server are ASCII addresses and it handled our domain as an ASCII domain with A-labels. Exchanging mail with other EAI mail systems worked. As with MS Outlook.com, the POP and IMAP servers do not have EAI support but often handled EAI messages adequately anyway.

    托管版 Exchange 服务器是微软 Office 365 套件的组成部分。我们创建了一个 O365 账户,并将其配置为处理我们的一个 IDN(国际化)域名。我们发现它仅达到 EAI Phase 1 就绪,而未达到 Phase 2 就绪。托管版 Exchange 服务器处理的所有地址均为 ASCII 地址,它将我们的域名作为 ASCII 域名处理,使用的是 A-label(即 Punycode)格式。与其他 EAI 邮件系统之间的邮件收发是正常的。与 MS Outlook.com 一样,其 POP 和 IMAP 服务器不具备 EAI 支持,但在大多数情况下仍能基本处理 EAI 邮件。

    《UASG030》文档测试结果部分的屏幕截图,其中高亮了 MS Exchange Server,其结果明确指出其为 All L1.

    综上所述,“IDN 域名在 Microsoft Exchange Server 中被当作 Punycode 处理”是设计中的预期行为;你没有办法直接设置一个叫做 我是@福瑞控.com 的邮箱,但你可以把发件人的显示名称改为 我是@福瑞控.com,作为一个折中方案。

    希望我的答案会对阐明此问题有所帮助 ;)


    * Claude Sonnet 4.6 在本回答的完成中亦有所贡献。

    此答案是否有帮助?

    0 个注释 无注释

  2. 匿名
    2026-04-10T14:47:04.7233333+00:00

    此消息为自动翻译,可能包含轻微的措辞错误。此外,由于我们的测试环境使用英文界面,截图将显示为英文。感谢您的理解! 

    您好 @Rui max, 

    关于当前域名未显示为您期望的正确名称的问题,需要由微软支持团队介入处理。 

    微软的技术支持工程师可以通过远程会话对该问题进行调查,核实后台配置,并运行必要的同步工具来解决此问题。如果问题需要进一步处理,他们还可以将工单升级至专门的团队进行更深入的分析。 

    建议全局管理员(Global Admin)创建一个 Microsoft 支持服务请求,以获得高级技术支持和诊断协助。有关如何获取支持的详细说明,请参考以下链接:  获取支持 - Microsoft 365 admin | Microsoft Learn 

    如需进一步协助,您也可以通过以下链接查找适合的联系电话:  客户服务电话号码 - Microsoft 支持 

    如果您的 Office 365 订阅是通过联合合作伙伴或经销商管理的,且全局管理员无法直接创建服务请求,请联系该经销商的支持团队。经销商可以协助提交请求并与 Office 365 支持团队进行协调。 

    对于将您转向相关开发团队支持,我们深表歉意。由于本社区版主在后台信息核查方面的权限有限,为了更快速、更有效地解决问题,我们建议通过上述正式支持渠道获取帮助。 

    再次感谢您的时间与理解。 


    注意: 如果您希望收到与此线程相关的电子邮件通知,请按照我们的文档中的步骤启用电子邮件通知。 

    此答案是否有帮助?

    0 个注释 无注释

你的答案

提问者可以将答案标记为“已接受”,审查方可以将答案标记为“已推荐”,这有助于用户了解答案是否解决了提问者的问题。