Erros Servidor Banco de dados SQL Server

Tatiana Jandira 480 Pontos de reputação
2026-03-11T22:02:07.01+00:00

Tivemos duas situações em um servidor de banco de dados com SQL Server 2022.

A primeira situação ocorreu erro quando estava sendo realizado rebuild e backup, deu erro no tempDB.

The operating system returned error 38(Reached the end of the file.) to SQL Server during a read at offset 0x0000013fe30000 in file 'T:\MSSQL\TEMPDBDATA\tempdb.mdf'. Additional messages in the SQL Server error log and operating system error log may provide more detail. This is a severe system-level error condition that threatens database integrity and must be corrected immediately. Complete a full database consistency check (DBCC CHECKDB). This error can be caused by many factors; for more information, see SQL Server Books Online. [SQLSTATE HY000] (Error 823).  The step failed.

Problema já ocorreu tres dias consecutivos, mas de forma intermitente.

Essa segunda situação ocorreu em dia e horário diferente :

Outra situação, no mesmo servidor foi que houve tentativa de conectar de forma externa na instancia e gerava o erro abaixo. Porém localmente conseguia acessar normal.Somente após reiniciar a instância que as conectividades foram normalizadas.

A duvida é : Esse problema que houve de conexão pode estar relacionado com a primeira situação ?

Imagem do usuário

SQL Server | Outro
SQL Server | Outro

Recursos e tópicos adicionais do SQL Server não abordados em categorias específicas


1 resposta

Classificar por: Mais útil
  1. Dio Xavier 296.6K Pontos de reputação Moderador Voluntário
    2026-03-11T23:24:11.21+00:00

    Olá

    Bem vinda à Comunidade Microsoft SQL Server.

    Boa noite, Tatiana. Obrigado por expor o seu cenário. Pelas informações nelas contidas foram identificadas duas ocorrências distintas:

    1. Erro 823 no tempDB. Associado a falha de I/O pelo Sistema Operacional comumente associado a falha em disco, storage, drivers ou sistema de arquivos. A solução neste caso requer a execução de verificação de integridade de bases:

    DBCC CHECKDB WITH NO_INFOMSGS, ALL_ERRORMSGS;

    • Verificar o SQL Server error log e Event ViewerSistema e aplicação) no horário de erro
    • Validar o volume "T": com verificação de disco e falhas no storage ou controladoras.
    1. Falha de conexão externa na instância: Como o acesso local funcionava e foi normalizado após reiniciar a instância pois é possível que tenha ocorrido instabilidade na rede, esgotamento de recursos ou bloqueio temporário do listener TCP/IP. As recomendações neste caso são:
      • Revisão do SQL log error no momento da falha
      • Validar configuração de rede no SQL Server Configuration Manager
      • Teste de conectividade externa pela porta da instância 1433

    Desejo boa sorte e avise-nos sobre o resultado.

    Se a resposta tiver ajudado a resolver o problema, por gentileza marque-a como Resposta Útil. Essa ação encerra a thread, sinaliza a solução correta e ajuda outras pessoas com a mesma dúvida a encontrarem a resposta com mais facilidade. Caso ainda precise de suporte ou tenha novas perguntas, fique à vontade para utilizar este mesmo post.

    Esta resposta foi útil?


Sua resposta

As respostas podem ser marcadas como ‘Aceitas’ pelo autor da pergunta e ‘Recomendadas’ pelos moderadores, o que ajuda os usuários a saber a resposta que resolveu o problema do autor.