과도한 데이터 증가로 인해 서비스 시작 실패

Park Bom 40 평판 포인트
2026-10-06T06:14:40.24+00:00

동적으로 변경되는 메타데이터로 인해 고유 데이터 시리즈가 과도하게 증가한 이후, 한 노드가 시작 과정에서 정상적으로 실행되지 않는 문제가 발생했습니다. 문제는 비정상적으로 많은 데이터 시리즈와 관련된 것으로 보입니다.

문제가 되는 메트릭을 식별하고, 영향을 받은 데이터를 안전하게 삭제하거나 정리한 후 서비스를 정상적으로 시작할 수 있는 방법을 안내해 주시겠습니까?

비즈니스용 Windows | Windows Server | 디바이스 및 배포 | 기타
댓글 0개 설명 없음

질문 작성자가 수락한 답변
Harry Phan 33,805 평판 포인트 독립 자문가
2026-10-06T14:25:00.9066667+00:00

Dear Mr. Park Bom,

동적으로 변경되는 메타데이터로 인해 고유 데이터 시리즈가 과도하게 증가하여 노드가 정상적으로 시작되지 않는 경우, 먼저 서비스 로그와 시리즈 카디널리티 정보를 확인하여 문제가 되는 메트릭을 식별해야 합니다. 특히 비정상적으로 많은 레이블 조합을 생성하는 메트릭과 해당 레이블을 확인한 후, 영향을 받는 데이터의 범위를 정확히 판단하는 것이 중요합니다. 문제가 되는 메트릭을 확인한 후에는 서비스를 중지하고 해당 제품에서 공식적으로 지원하는 보존 정책, 컴팩션 또는 데이터 삭제 절차를 사용하여 데이터를 정리해야 하며, TSDB 내부 파일을 직접 삭제하는 방법은 데이터 손상을 유발할 수 있으므로 권장하지 않습니다. 서비스가 정상적으로 시작되지 않아 일반적인 정리 작업을 수행할 수 없는 경우에는 사용 중인 제품 및 버전에 맞는 공식 복구 또는 오프라인 데이터 삭제 절차를 적용해야 합니다. 데이터 정리 후 노드를 다시 시작하고 서비스 상태와 데이터 시리즈 카디널리티가 정상적으로 감소했는지 확인하시기 바랍니다. 정확한 명령어와 복구 절차를 안내해 드리기 위해 사용 중인 제품명 및 버전과 함께 노드 시작 시 발생하는 오류 메시지 또는 관련 로그를 제공해 주시면 추가로 확인해 드리겠습니다.

감사합니다.

Harry P.

이 대답이 도움이 되었나요?

1명이 이 답변이 도움이 된다고 생각했습니다.
댓글 0개 설명 없음

0 추가 답변

정렬 기준: 가장 유용함

답변

질문 작성자는 답변을 '승인됨'으로 표시하고, 중재자는 답변을 '추천됨'으로 표시할 수 있습니다. 이를 통해 사용자는 해당 답변이 작성자의 문제를 해결했다는 것을 알 수 있습니다.