汎用v1ストレージアカウントの汎用v2へのアップグレードに失敗する

奥野 高明 25 評価のポイント
2026-10-01T22:57:33.5366667+00:00

自社のAzure環境で利用しているストレージアカウントの中で汎用v1のものがいくつかあったので、Azureポータル上で汎用v2へのアップグレード操作を実施しました。しかし、エラーが表示されアップグレードに失敗したストレージが存在しています。

表示されたエラー:"Values for request parameters are invalid: sku."

当該ストレージはかなり前に作成され、レプリケーションが「ゾーン冗長ストレージ (ZRS クラシック)」になっているため、これが原因ではないかと考えているのですが、この認識は正しいでしょうか。

また、上記エラーが表示されたストレージアカウントを汎用v2にアップグレードする他の方法がありましたらご教示いただければと思います。

Azure Blob Storage
Azure Blob Storage

非構造化データをクラウド内に BLOB として格納する Azure サービス。

0 件のコメント コメントはありません

1 件の回答

並べ替え方法: 最も役に立つ
  1. チャブーン 7,681 評価のポイント MVP ボランティア モデレーター
    2026-10-02T02:36:57.72+00:00

    チャブーンです。

    この件ですが、直接の回答については、以下のページに書いてある通りになる、かと思います。

    ZRS 冗長を使用する汎用 v1 (GPv1) を GPv2 にアップグレードする

    • GPv2 を使用できるリージョンにSAを移動して、そちらでアップグレードを行う
    • GPv1 ZRSはLRS、GRS、または RA-GRS との間でレプリケーション変換はできない(のでムリに試さない)
    • GPv2 を使用できるリージョンでもエラーが出る場合、Azureプランによるサポートに支援を依頼する
    • (あまりお奨めしませんが)何もしないでおくとMS側で自動変換してくれるのでそれを待つ
      期限までに移行しないとどうなるか

    この回答は役に立ちましたか?

    0 件のコメント コメントはありません

お客様の回答

質問作成者は回答に "承認済み"、モデレーターは "推奨" とマークできます。これにより、ユーザーは作成者の問題が回答によって解決したことを把握できます。