Accessで印刷すると書体が変更されてしまう

100 0 評価のポイント
2026-09-18T06:36:55.7366667+00:00

AccessでHGPゴシックを使い印刷すると書体が変更されてしまう。HGでしか反映されない文字のため書体はかえられません。

Microsoft 365 と Office | Access | その他 | Windows

3 件の回答

並べ替え方法: 最も役に立つ
  1. motosan 3,570 評価のポイント
    2026-09-21T11:50:52.49+00:00

    HGでしか反映されない文字のため書体はかえられません。

    Word ですが 「MS ゴシック」 でも 飴󠄀 は表示できます。

    Access では表示できないのでしょうか?

    • Windows 11 Pro 25H2 26200.9457
    • Microsoft® Word for Microsoft 365 MSO (バージョン 2608 ビルド 16.0.20326.20072) 64 ビット

    タスクバーの右側の「A/あ」を右クリックして変換候補の一覧にすべて表示するようにします。

    ユーザーの画像

    • [設定] > [全般] > [文字の種類と文字セット] - [変換候補の一覧に含める文字セットを選択する] - 「すべて」

    「あめ」で変換すると下記のように表示されます。

    ユーザーの画像

    Access では表示されないのでしょうか?

    追記)

     上記の設定は変換候補が追加されるだけで、上記の設定に関係なく正しい字体で表示されます。

    もしかしたらWindows の 飴󠄀 の文字コードとHGの文字コードは違っているのかもしれません。

    この回答は役に立ちましたか?

    1 人がこの回答が役に立ったと思いました。

  2. JeseminQH 925 評価のポイント 独立アドバイザー
    2026-09-18T07:43:26.3333333+00:00

    免責事項:このメッセージは自動翻訳されたものです。そのため、表現に多少の誤りがある可能性があります。また、テスト環境では英語のインターフェイスを使用しているため、スクリーンショットも英語で表示されます。あらかじめご了承ください。

    こんにちは @100

    この現象は、印刷時のフォントの置き換え(フォント置換)が原因である可能性があります。Microsoft Accessでは、画面表示と印刷出力で異なるフォントが使用される場合があり、プリンタードライバーが「HGPゴシック」フォントや特定の文字を正しく処理できないと、別のフォントに置き換えられることがあります。

    以下の手順をお試しください。

    1. 別の日本語フォントを試す
    • 対象のレポートを「デザイン ビュー」で開きます。
    • フォントが変わってしまうテキストボックスやラベルを選択します。
    • ユーザーの画像
    • F4キーを押して「プロパティ シート」を開きます。
    • 「書式」タブを選択します。
    • フォント名をHGP GothicからMS GothicまたはMeiryoに変更してください。
    • ユーザーの画像
    • レポートを保存します。
    • 印刷プレビューを開いて、仕上がりを確認してください。
    • レポートを再度印刷します。

    フォントを変更すると、文字間隔、改行位置、またはテキストのサイズに影響が出る可能性があるため、変更後にレポートのレイアウトを確認してください。

    1. レポートをPDFにエクスポートする
    • Accessで対象のレポートを開きます。
    • 外部データ > PDFまたはXPSを選択してください。
    • ユーザーの画像
    • または、「印刷」ウィンドウから「Microsoft Print to PDF」を選択します。
    • レポートをPDFとして保存します。
    • Microsoft EdgeまたはAdobe Acrobat ReaderでPDFを開きます。
    • フォントが正しく表示されているか確認します。
    • 実際のプリンターを使用してPDFを印刷します。
    1. プリンターの設定を確認する

    HGP Gothicフォントをどうしても使用する必要がある場合は、プリンタードライバーにフォント処理オプションが用意されているかどうかを確認してください。

    • Windowsの設定を開き、「Bluetoothとデバイス」>「プリンターとスキャナー」を選択します。
    • 対象のプリンターを選択し、「プリンターのプロパティ」を開きます。
    • デバイス設定タブに移動してください。
    • フォント置換テーブルまたはTrueTypeフォントの処理設定を探してください。
    • 設定を「デバイスフォント / デバイスフォントで置換」から「ソフトフォントとしてダウンロード」または「ビットマップ / グラフィックとして送信」に変更します。
    • 利用可能な場合は、デバイスフォントへの置き換えを無効にし、フォントをダウンロードするか、グラフィックとして印刷するオプションを選択します。
    • 変更を適用し、再度テスト印刷を行います。

    なお、これらのオプションは、すべてのプリンターモデルやドライバーで表示されるわけではありません。

    1. プリンタードライバーを更新する
    • プリンターメーカーのサポートWebサイトにアクセスします。
    • プリンターのモデル名を検索します。
    • 最新の完全版プリンタードライバーをダウンロードしてインストールします。
    • 求められた場合は、コンピューターを再起動します。
    • 改めてレポートの動作をご確認ください。

    ご提案した手順で問題が解決することを願っております。もし不都合が生じたり、さらなるサポートが必要な場合は、お気軽に返信にて結果をお知らせください。

    この回答は役に立ちましたか?


  3. M_Marl 9,870 評価のポイント
    2026-09-18T07:07:19.23+00:00

    その現象は何時から起きてますか?

    365ですと、今日、パージョン 2608(ビルド 20326.20158) が配信されました

    この更新を適応してからであれば、Microsoft 365/Officeを以前のバージョンに戻すことで改善するかもしれません

     参照:[記事] クイック実行版の Office をロールバックする方法

     ※Accessのみ戻す、という事はできません M365/Officeアプリすべてが以前のバージョンに戻ります※

    バージョンを戻したら直った場合は、その更新にバグがあるので、フィードバックで米本社の開発チームへ報告してください

    フィードバックは、Accessですので、「ヘルプ」タブにある「フィードバック」を利用してください
    標準アプリのフィードバックHubアプリよりは手間がかからないと思います

    この回答は役に立ちましたか?


お客様の回答

質問作成者は回答に "承認済み"、モデレーターは "推奨" とマークできます。これにより、ユーザーは作成者の問題が回答によって解決したことを把握できます。