Office365で 2026/04/21にリリースされた バージョン 2604 (ビルド 19929.20090)を適用すると、Accessで長いテキストの項目を含むレコード追加がエラーになる

栗原泰介 25 評価のポイント
2026-04-26T23:45:17.81+00:00

Office365で 2026/04/21にリリースされた バージョン 2604 (ビルド 19929.20090)を適用後、AccessでSQLServerとODBC接続でリンクしたテーブルを介して長いテキストの項目を含むテーブルへレコードの追加を行うと「=/付近に不適切な構文があります(#102)」のエラーになります。適用前は問題なく追加できていました。

Microsoft 365 と Office | Access | ビジネス向け | Windows
0 件のコメント コメントはありません

質問作成者が受け入れた回答
Anonymous
2026-04-27T01:54:07.7433333+00:00

注: この回答は自動翻訳されています。そのため、文法上の誤りや不自然な表現が含まれる場合があります。

こんにちは 栗原泰介

Microsoft Q&A フォーラムにお問い合わせいただき、また問題の詳細をご共有いただきありがとうございます。ご不便をおかけしており申し訳ございません。

調査の結果、Access バージョン 2604(ビルド 19929.20090)において、ODBC 経由でリンクされた SQL Server テーブルの Long Text(NVARCHAR(MAX))フィールドにデータを挿入する際に、同様の現象が発生しているケースが確認されています。

当面の回避策として、以下をお試しください。

  • ODBC Driver 18 for SQL Server を使用する(本事象の影響を受けないと考えられます)。
  • 以下のレジストリキーを設定して、関連する動作を無効化する: HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\ExperimentEcs\Overrides Microsoft.Office.Access.UseOutputInsertedForOdbcIdentity = false
  • 本事象が発生しない Microsoft 365 バージョン 2603 へロールバックする。

ご参考までに: 以前のバージョンの Office に戻す方法 - Microsoft サポート

  • 一時的な回避策として、まず Long Text フィールドに値を入れずにレコードを保存し、その後に該当フィールドを更新する。

詳細については、以下をご参照ください:ODBC INSERT on linked SQL Server tables in Access Fails

注: 上記の情報は参考として提供されています。これらのサイトは Microsoft によって管理されておらず、掲載されているソフトウェアや情報の品質、安全性、適合性について Microsoft は保証いたしません。リンク先の内容をご利用の際は、リスクをご理解の上でご判断ください。

本スレッド内で案内されているリソースは、英語のみで提供されています。日本語のコンテンツをご希望または必要とされる方には、ご不便をおかけしますことを心よりお詫び申し上げます。内容の理解にサポートが必要な場合は、信頼できる翻訳ツールまたはサービスのご利用をお勧めします。

本情報がお役に立てば幸いです。


注: このスレッドに関連するメール通知を受け取りたい場合は、ドキュメントの手順に従ってメール通知を有効にしてください。

この回答は役に立ちましたか?

5 人がこの回答が役に立ったと思いました。

0 件の追加の回答

並べ替え方法: 新しい順

お客様の回答

質問作成者は回答に "承認済み"、モデレーターは "推奨" とマークできます。これにより、ユーザーは作成者の問題が回答によって解決したことを把握できます。