プライベート ネットワークをプロビジョニングし、オンプレミスのデータセンターに必要に応じて接続するために使用する Azure ネットワーク サービス。
回答を英語から翻訳しているため、文法に不備があるかもしれませんが、何卒ご容赦ください。
こんにちは。@
Microsoft Q&Aにお問い合わせいただき、ありがとうございます。
新しいvMXインスタンスをデプロイしようとした際に、デプロイが失敗してしまうという事象が発生しているとのこと、承知いたしました。
- デプロイの失敗は、サブネットのサイズが小さすぎる(/29)ことが原因でしょうか?
はい、その可能性が極めて高いと考えられます。
Azureでは技術的には/29(8個のアドレス)のサブネットも許可されていますが、実際には、どのサブネットにおいてもプラットフォーム利用のために5個のIPアドレスが予約されます。そのため、/29のサブネット内で実際に利用可能なIPアドレスは、わずか3個しか残りません。
Cisco Meraki vMXのデプロイには、以下のIPアドレス割り当てが必要となります。
プライマリNICへのIPアドレス割り当て
プロビジョニング、診断、ヘルスチェック、および再デプロイの実行中に必要となる追加のIPアドレス利用
このように利用可能なIPアドレスが極めて限られている場合、特に再デプロイや更新処理を行う際に、デプロイが失敗したり、システムが不安定になったりする恐れがあります。
- サブネットのサイズを小さく設定した場合、どのような影響(パフォーマンスや拡張性への影響)がありますか?
これはスループットやパフォーマンスに関する問題ではなく、プラットフォーム側のIPアドレス枯渇や、リソースのライフサイクル管理に関する問題となります。
- サブネットの最小サイズとして、/26または/27は許容範囲内でしょうか?
はい、許容範囲内です。アドレス空間に十分な余裕がある場合は一般的に/24が推奨されますが、以下のガイドラインが広く受け入れられています。
/26 → 長期的な安定性を確保するための推奨最小サイズ
/27 → アドレス空間に制約がある場合に許容可能なサイズ
/29 → vMXのようなネットワーク仮想アプライアンス(NVA)には推奨されません
もしHub VNetのアドレス空間を/24まで拡張することが難しい場合は、/26を選択するのが安全かつ安定した運用につながります。また、/27でも許容範囲内ではありますが、アドレス空間の余裕はかなり少なくなります。お客様の要件に合わせて、適切なアドレス空間を作成してください。
- 既存のvMXサブネットのサイズを拡張する際、現在稼働中のデプロイ(リソース)に影響を与えずに変更することは可能でしょうか?
いいえ、不可能です。Azureでは、サブネット内にリソースが既に配置されている場合、そのサブネットのサイズを「インプレース(稼働中のまま)」で変更・拡張する機能はサポートされていません。サブネットのサイズを拡張するには、以下のいずれかの対応が必要です。
推奨されるアプローチ(推奨)
十分なサイズ(例:/26 または /27)を持つ新しいサブネットを作成する
新しいサブネットに新しい vMX をデプロイする
VPN およびルーティングのトラフィックを移行する
古い vMX を廃止する
vMX のデプロイ時に発生したエラーのスクリーンショット、またはエラーメッセージの全文をプライベートメッセージにてお送りいただければ、そのエラーがサブネットの問題に起因するものかどうかを特定するお手伝いが可能です。上記の情報が解決の助けとなったか、あるいは本件に関してさらにサポートが必要かについて、お知らせいただけますと幸いです。
この回答がお役に立ちましたら、「回答を承認」をクリックし、ぜひ「いいね」をお願いいたします。この回答に関して追加のご質問がございましたら、「コメント」をクリックしてください。