「event id:20491」で Web 検索すると事例が多数出てきますが、原因はケースバイケースのようです。地道にトラブルシューティングを行うか、以下の事例のように強制的にアンマウントするタスクを実行させるか、という所のようです。
Remote Desktop Serviceで正常にログオフ出来ない等の問題について
Windows Server 2019環境でリモートデスクトップ環境を構築しています。
サーバー構成は複数のRDセッションホスト、1台の接続ブローカー兼ライセンスサーバー上にユーザープロファイルディスクを管理している構成になっています。
運用開始して2~3年になるのですが、今回の質問となるのはリモートデスクトップ接続利用終了時にユーザーがログオフしているのですが、リモートデスクトップサービス上はユーザーの接続がない状態になるのですが、ユーザープロファイルディスクがアンマウント出来ていない状態になることが稀にあります。
リモートデスクトップサービス上にはユーザーの接続がないため、次回接続時にユーザープロファイルディスクをマウントしようとするのですが、前回のログオフ時にディスクの取り外しが正常にできていないため、ユーザーが正常に利用出来ないという状況になっているのだと思われます(下に該当と思われるログを記載しています)
この状況が発生した場合の対処は複数存在するセッションホストのどのサーバーにマウントされているかを特定した上でそのサーバーにログインし、ディスクを切り離すという作業を行っております。
このように発生した場合に対処は可能なのですが、この症状が改善したいのですが必ず発生するわけでもなく、調査に行き詰まっている状態です。
ログ1(event id:20491)
Microsoft-Windows-TerminalServices-RemoteConnectionManager
リモート デスクトップ サービスは、SID が S-1-5-21-xxxxxxxxxxxxxxxx のユーザー アカウントのユーザー ディスクを切断できませんでした。エラー コード: 0xAA。93
ログ2(event id:20496)
Microsoft-Windows-TerminalServices-RemoteConnectionManager
リモート デスクトップ サービスは、SID が S-1-5-21-xxxxxxxxxxxxxxxx のユーザー アカウントのユーザー デスクトップを適用できませんでした。このユーザーに一時プロファイルを適用できませんでした。このユーザーには標準プロファイルが割り当てられ、ユーザーがログオフするとユーザーの状態は破棄されます。ユーザー プロファイル ディスクの設定が正しいことを確認してください。エラー コード: 0xAA。93
このディスクの切り離しの失敗が出始めると、複数のユーザーで発生することがありますが、必ずこのユーザーで発生するという特定の条件はなさそうです。
設定変更の見直しをするなど何か対応方法などありますでしょうか?
ビジネス向け Windows | Windows Server | ユーザー エクスペリエンス | リモート デスクトップ サービスとターミナル サービス
-
Hebikuzure aka Murachi Akira 335.3K 評価のポイント MVP ボランティア モデレーター2025-11-03T09:01:41.78+00:00