【SharePoint Online】powershellで、接続エラーが発生

Anonymous
2024-07-03T08:43:56+00:00

サーバー(Windows Server 2016 Datacenter)で、powershellを利用しSharePoint Onlineに接続しています。

2021年からバッチは実行されているのですが、今年の6月から "ExecuteQuery" を呼び出し中に例外が発生しました: "リモート サーバーに接続できません。"とエラーが発生するようになりました。

長く動いていた実績があるので、プログラムの問題ではないと思いますが、エラーの原因について、心当たりがあればご教示いただけますでしょうか。

また、作業用のPCでバッチを実行すると、正常終了する事は確認しています。

ソースコード抜粋


$objPassword = ConvertTo-SecureString $strPassword -AsPlainText -Force;

$objCredentials = New-Object Microsoft.SharePoint.Client.SharePointOnlineCredentials($strUser, $objPassword);

$objCtx = New-Object Microsoft.SharePoint.Client.ClientContext($strSiteUrl);

$objCtx.Credentials = $objCredentials;

$objSite = $objCtx.Site;

$objCtx.Load($objSite);

$objCtx.Load($objSite.RootWeb);

$objCtx.ExecuteQuery(); ←ここで、エラーになります。


Microsoft 365 と Office | SharePoint | ビジネス向け | その他

ロックされた質問。 この質問は、Microsoft サポート コミュニティから移行されました。 役に立つかどうかに投票することはできますが、コメントの追加、質問への返信やフォローはできません。

0 件のコメント コメントはありません

4 件の回答

並べ替え方法: 古い順
  1. Anonymous
    2024-07-03T09:09:39+00:00

    管理者設定に関する内容は、組織のIT管理者に聞いて下さい。

    IT管理者が分からなければ、Microsoftサポート窓口に聞いてくれます。

    又、海外コミュニティで聞く手もあるかも?

    Microsoft Q&A (en-us版)

    ├ SharePoint
    ├ SharePoint Server Management

    └ SharePoint Development

    ※ 質問内容によっては、閲覧者・回答者が多い海外コミュニティをお勧めします。

      Microsoft Q&A では、英語が推奨されています。(日本語を読み解いてくれる人は少なそうです。)

      タグ名は約390種類定義されています。適切なタグ(複数可)を付与した方が回答を得られ易いです。

      (技術的な質問も受け付けている様です。)

    この回答は役に立ちましたか?

    0 件のコメント コメントはありません
  2. Hebikuzure aka Murachi Akira 335.3K 評価のポイント MVP ボランティア モデレーター
    2024-07-04T08:09:12+00:00

    また、作業用のPCでバッチを実行すると、正常終了する事は確認しています。

    この作業用 PC の Windows のバージョン・ビルドは何ですか?

    ※ TLS のバージョン周りの問題かもと言う山勘。

    この回答は役に立ちましたか?

    0 件のコメント コメントはありません
  3. Anonymous
    2024-07-04T08:21:38+00:00

    ご回答ありがとうございます。Windows のバージョン・ビルドは以下の通りです。

    バージョン 22H2(OSビルド 19045.4529)

    この回答は役に立ちましたか?

    0 件のコメント コメントはありません
  4. Hebikuzure aka Murachi Akira 335.3K 評価のポイント MVP ボランティア モデレーター
    2024-07-05T07:33:33+00:00

    クライアントでトランスポート層セキュリティ (TLS) 1.2 を有効にする方法 - Configuration Manager | Microsoft Learn

    この辺りを参考に、サーバー側で TLS 1.2 と強力な暗号が有効かどうかは確認されても良いかも。

    外していたら、Microsoft Q&A(英語版)に SharePoint タグをつけて投稿されることをお勧めします。

    この回答は役に立ちましたか?

    0 件のコメント コメントはありません