unable to upgrade postgres database

Sylvain Michel 20 Points de réputation
2026-07-15T01:49:42.82+00:00

I receive this error when trying to upgrade my postgres database in Canada-Central.

I have tried yesterday also. Same answer.

Capacity is not available in this region/zone. Please retry after some time. (Code: CapacityNotAvailable)

Azure Database pour PostgreSQL
Azure Database pour PostgreSQL

Service de base de données PostgreSQL managé Azure pour le développement et le déploiement d’applications.


1 réponse

  1. Smaran Thoomu 35,870 Points de réputation Personnel externe Microsoft Modérateur
    2026-07-16T02:49:41.9266667+00:00

    Bonjour Sylvain,

    Merci pour ces précisions.

    Étant donné que vous modifiez la SKU de calcul de votre serveur, l'erreur CapacityNotAvailable indique que la capacité de calcul requise n'est actuellement pas disponible dans la région Canada Central, en particulier pour la Zone de disponibilité 3.

    Il s'agit généralement d'une contrainte temporaire de capacité plutôt que d'un problème lié à votre serveur Azure Database for PostgreSQL Flexible Server.

    Vous pouvez essayer les actions suivantes :

    • Réessayer l'opération ultérieurement, car de la capacité peut redevenir disponible.
    • Si votre charge de travail le permet, essayer une autre SKU prise en charge.
    • Si cela est possible dans votre environnement, essayer une autre Zone de disponibilité prise en charge.

    Si le problème persiste malgré plusieurs tentatives et qu'aucune de ces options n'est envisageable, nous vous recommandons d'ouvrir une demande auprès du Support Azure afin que l'équipe concernée puisse vérifier la disponibilité de la capacité dans cette région.

    Merci.

    Cette réponse a-t-elle été utile ?

    0 commentaires Aucun commentaire

Votre réponse

Les réponses peuvent être marquées comme « Acceptées » par l’auteur de la question et « Recommandées » par les modérateurs, ce qui aide les utilisateurs à savoir que la réponse a résolu le problème de l’auteur.