Nous avons un profil FrontDoor CDN classic avec des certificats gérés qui a automatiquement commencé à migrer vers Azure Front Door standard en raison de l'expiration des certificats.
https://azure.microsoft.com/fr-fr/updates?
La migration est bloquée depuis au moins 6 heures, peut être plus.
Nous avons migré manuellement un autre profil du même type avec succès, mais nous ne pouvons pas faire de même pour celui-ci, car le domaine personnalisé est utilisé par le CDN en cours de migration, et toute tentative de suppression du domaine personnalisé échoue avec le message « La ressource ne peut pas être modifiée alors qu'elle est en cours de migration ».
Nous avons essayé de redémarrer et d'annuler la migration avec Enable-AzFrontDoorCdnProfileMigration et Stop-AzFrontDoorCdnProfileMigration, mais les deux échouent avec respectivement « L'opération demandée ne peut pas être exécutée sur l'entité dans l'état actuel » et « Le profil FrontDoorCdn fourni n'existe pas ».
Comment pouvons-nous annuler cette migration ?
Message original en anglais :
Automatic migration from Microsoft CDN (classic) to Front Door Standard stuck for at least 6 hours and counting
We have a CDN classic with managed certificates that automatically started migrating to Azure Front Door standard due to the expiration of the of the certificates.
The migration has been stuck for at least 6 hours now.
We successfully migrated another CDN classic profile manually, but cannot do the same for this one, as the custom domain is in use by the CDN being migrated, and trying to remove the custom domain fails with "The resource cannot be modified when it is being migrated"
We tried restarting and aborting the migration with Enable-AzFrontDoorCdnProfileMigration Stop-AzFrontDoorCdnProfileMigration, but both fail with "The requested operation cannot be executed on the entity in the current state." and "Provided FrontDoorCdnProfile does not exist." respectively.
How Can we abort this migration ?