Impossible d'afficher la liste des champs d'un TCD

Anonyme
2016-01-26T12:04:29+00:00

J'ai dû charger un modèle Excel posant problème.

J'avais un pb de menu contextuel qui est résolu par une macro appropiée.

Je n'arrive pas maintenant à visualiser la liste des champs des tableaux croisés dynamiques.

Avez vous une solution :)

Microsoft 365 et Office | Excel | Pour la maison | Windows

Question verrouillée. Cette question a été migrée à partir de la Communauté Support Microsoft. Vous pouvez voter pour indiquer si elle est utile, mais vous ne pouvez pas ajouter de commentaires ou de réponses ni suivre la question.

0 commentaires Aucun commentaire
Réponse acceptée par l’auteur de la question
DanielCo 107.1K Points de réputation
2016-02-15T17:13:19+00:00

Ferme Excel et essaie aussi (et surtout) de supprimer le fichier :

C:\Users\daniel\AppData\Roaming\Microsoft\Excel\Excel15.xlb (en remplaçant "daniel" par ton nom d'utilisateur. Un nouveau fichier sera recréé automatiquement quand tu ouvriras Excel.

Note que le dossier "AppData" est un dossier caché. Il faudra peut-être que tu ailles dans l'explorateur Windows, onglet Affichage, Options, onglet Affichage, Fichiers et dossiers cachés, coche Afficher les fichiers, dossiers et lecteurs cachés

Daniel

Cette réponse a-t-elle été utile ?

10 personnes ont trouvé cette réponse utile.
0 commentaires Aucun commentaire

25 réponses supplémentaires

  1. DanielCo 107.1K Points de réputation
    2016-01-28T16:15:25+00:00

    Alors, c'est soit un classeur se trouvant dans le dossier XLSTART, soit une macro complémentaire qui provoque l'erreur. Clique sur l'onglet "Développeur" puis sur "Compléments Excel" Désactive un à un ceux qui sont cochés. A chaque fois, ferme et redémarre Excel (normalement). Continue tant que l'erreur se produit. Si elle ne se produit plus, c'est le dernier complément désactivé qui provoque l'erreur. Si le problème persiste, fais de même avec les compléments COM.

    Si le problème persiste, ouvre le dossier XLSTART qui doit se trouver ici :

    C:\Users\daniel\AppData\Roaming\Microsoft\Excel\XLSTART (remplace "daniel" par ton nom d'utilisateur).

    Déplace lees classeurs s'y trouvant, un à un dans un autre dossier. Ferme et redémarre Excel à chaque fois et teste.

    Daniel

    Cette réponse a-t-elle été utile ?

    1 personne a trouvé cette réponse utile.
    0 commentaires Aucun commentaire
  2. DanielCo 107.1K Points de réputation
    2016-01-26T15:39:36+00:00

    Exécute :

    Sub reset() <br><br>Dim C As CommandBar <br><br>On Error Resume Next <br><br>For Each C In Application.CommandBars <br><br>    C.Enabled = True <br><br>    C.Visible = True <br><br>Next C <br><br>On Error GoTo 0 <br><br>End Sub

    Si les command bars réapparaissent et disparaissent après fermeture et réoouverture d'Excel, démarre celui-ci en maintenant la touche Ctrl enfoncée (mode "sans échec"). Teste.

    Daniel

    Cette réponse a-t-elle été utile ?

    1 personne a trouvé cette réponse utile.
    0 commentaires Aucun commentaire
  3. Anonyme
    2016-01-26T12:40:05+00:00

    Merci Daniel mais ceci est la démarche habituelle. 

    Mon pb est que le bouton est inactif 😒

    Cette réponse a-t-elle été utile ?

    0 commentaires Aucun commentaire
  4. DanielCo 107.1K Points de réputation
    2016-01-26T12:21:16+00:00

    Bonjour,

    Clique dans le TCD. Clique sur l'onglet "Analyse", sur le bouton "Afficher" et sur "Liste de champs' :

    Daniel

    Cette réponse a-t-elle été utile ?

    0 commentaires Aucun commentaire