Problemas para enviar data de event hub a next-gen clouwdstrike

Juan Pezoa Soto 0 Puntos de reputación
2025-10-13T15:32:44.83+00:00

Estimados, tengo problemas cuando configuro el conector de next-gen de cloudstrike con los datos de la aplicacion que registé en azure y los datos del inquilino, ya que obtengo el siguiente error.

Ingest credentials are not valid. Check permissions are given as per the connector requirements","status_code":403,"@error":true,"@timestamp":"2025-10-13T14:41:29Z","error_count":1}

Que deberia revisar? Ya valide que la app este correctamente registrada (en la app no encontré que deba configurar algun permiso), le asigné rol de colaborador a la app en azure en el espacio de nombres de trabajo. Verifique que existe la politica: RootManageSharedAccessKey y que tiene los permisos send, listen y manage. Creé un consumer group personalizado para estar mas seguro, pero sigo obteniendo el mismo error.

Que mas podría validar?

Azure Event Hubs
Azure Event Hubs

Un servicio de ingesta de datos en tiempo real de Azure.


1 respuesta

Ordenar por: Muy útil
  1. Manoj Kumar Boyini 19,590 Puntos de reputación Personal externo de Microsoft Moderador
    2025-10-14T10:46:51.3533333+00:00

    Hola Juan Pezoa Soto,

    Bienvenido a la plataforma de preguntas y respuestas de Microsoft. Gracias por comunicarte y espero que estés bien.

    Entiendo la frustración con el error "Las credenciales de ingestión no son válidas" que estás viendo al conectar CrowdStrike con Azure Event Hub. Vamos a revisar algunas comprobaciones sencillas para que esto funcione:

    1.Verificar PermisosAunque hayas asignado el rol de colaborador, asegúrate de que tu aplicación de Azure tenga el rol de Remitente de Datos de Azure Event Hubs en el espacio de nombres del Event Hub. Este rol está diseñado específicamente para permitir el envío de datos al Event Hub.

    2.Política de acceso compartidoMencionaste que existe RootManageSharedAccessKey, lo cual es bueno. Pero vale la pena crear una nueva política de acceso compartido con solo el permiso de Enviar en tu Event Hub. Luego actualiza tu conector para usar la cadena de conexión de esta nueva política.

    3.Cadena de conexión correctaVerifica que la cadena de conexión que estás utilizando incluya el nombre correcto del Event Hub (EntityPath), el espacio de nombres y las claves, y que esté formateada así:
    Endpoint=sb://<TuEspacioDeNombres>.servicebus.windows.net/;SharedAccessKeyName=<NombreClave>;SharedAccessKey=<Clave>;EntityPath=<NombreEventHub>

    4.Las credenciales son válidasAsegúrese de que cualquier secreto del cliente o certificados utilizados para la autenticación sigan activos y no hayan expirado ni sido revocados.

    5.Configuración de CrowdStrikeRevise la documentación de CrowdStrike para confirmar si se requieren permisos o configuraciones adicionales en su plataforma.

    6.Verificaciones de RedSi su espacio de nombres de Event Hub tiene configuraciones de firewall o restricciones de IP, asegúrese de que las IP de CrowdStrike estén permitidas.

    Si sigue estos pasos y aún enfrenta problemas, por favor comparta qué método de autenticación está utilizando CrowdStrike y cualquier otro detalle de error que reciba. ¡Estoy feliz de ayudarle a resolverlo más a fondo!

    Si la respuesta es útil, por favor haga clic en "Aceptar respuesta" y amablemente vote a favor. Si tiene preguntas adicionales sobre esta respuesta, haga clic en "Comentar".

    Gracias,
    Manoj

    ¿Le ha resultado útil esta respuesta?

    0 comentarios No hay comentarios

Su respuesta

Las respuestas pueden ser marcadas como "Aceptadas" por el autor de la pregunta y "Recomendadas" por los moderadores, lo que ayuda a los usuarios a saber que la respuesta ha resuelto el problema del autor.