Follow my guide to remove WSUS fully and reinstall. It sounds like you didn't fully remove it.
https://www.ajtek.ca/wsus/how-to-remove-wsus-completely-and-reinstall-it/
This browser is no longer supported.
Upgrade to Microsoft Edge to take advantage of the latest features, security updates, and technical support.
Hi,
I recently upgraded Windows Server from 2016 to 2022!
In post-install processes, I receive the following error for the WSUS service:
Log file is located at C:\Users\m-alizadeh\AppData\Local\Temp\\WSUS_PostInstall_20220223T152505.log
Post install is starting
Fatal Error: The schema version of the database is from a newer version of WSUS
than currently installed. You must either patch your WSUS server to at least
that version or drop the database.
Furthermore, in the WSUS console there is the following error:
The WSUS administration console was unable to connect to the WSUS Server via the remote API.
Verify that the Update Services service, IIS and SQL are running on the server. If the problem persists, try restarting IIS, SQL, and the Update Services Service.
The WSUS administration console was unable to connect to the WSUS Server via the remote API.
Verify that the Update Services service, IIS and SQL are running on the server. If the problem persists, try restarting IIS, SQL, and the Update Services Service.
System.Net.Sockets.SocketException -- No connection could be made because the target machine actively refused it 192.168.0.1:8530
Source
System
Stack Trace:
at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)
** this exception was nested inside of the following exception **
System.Net.WebException -- Unable to connect to the remote server
Source
Microsoft.UpdateServices.Administration
Stack Trace:
at Microsoft.UpdateServices.Administration.AdminProxy.CreateUpdateServer(Object[] args)
at Microsoft.UpdateServices.UI.SnapIn.Scope.ServerSummaryScopeNode.GetUpdateServer(PersistedServerSettings settings)
at Microsoft.UpdateServices.UI.SnapIn.Scope.ServerSummaryScopeNode.ConnectToServer()
at Microsoft.UpdateServices.UI.SnapIn.Scope.ServerSummaryScopeNode.get_ServerTools()
***I did the following actions, which were unsuccessful:
It would be highly appreciated if anybody could help me.
Thanks in advance***
Follow my guide to remove WSUS fully and reinstall. It sounds like you didn't fully remove it.
https://www.ajtek.ca/wsus/how-to-remove-wsus-completely-and-reinstall-it/
Hi,
Thanks for your posting in Q&A.
Agree with AJTek-Adam-J-Marshall, the issue may be WSUS is not removed completely.
We need to:
Remove WSUS Role and Windows Internal Database (WID) Feature.
Remove C:\WSUS or where ever the WSUSContent folder resides.
Remove C:\Windows\WID (specifically: delete the SUSDB.mdf and SUSDB_log.ldf in C:\Windows\WID\Data). If you don't remove the WID role and its files on a reinstall, it will re-attach to the same database.
In IIS, remove the 'WSUS Administration' website and the 'WsusPool' Application Pool if they still exist.
Restart the server and re-add the WSUS And WID Roles. Let it install, and then restart the server again.
Now try to do the post-installation configuration.
If this doesn't work, disjoin the server from the domain, and restart. Try the post-installation steps again. If it works, the issue is a policy on your domain that is causing the issues. You can then rejoin the server to the domain.
After you've removed WSUS completely following the instructions above, you can then go ahead and install it again if you so choose.
If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.
This is why Microsoft does not recommend installing WSUS on a Domain Controller. What you've done is against recommendations and what has happened is the groups WSUS needs to operate are no longer 'local' because a DC does not have any 'local' groups.
You cannot disjoin a domain controller from a domain unless you are demoting it to a member server first and then disjoining it.
You are better to try to fix this problem than to disjoin it.
Create 2 Domain Local groups
Name: WSUS Administrators
Description: Members of this group can administer the Windows Server Update Services role.
Name: WSUS Reporters
Description: Members of this group can generate reports but cannot approve updates or configure the Windows Server Update Services role.
Then try to run the postinstall again.
Hello @Amandayou-MSFT
The topic is on Windows Server 2022
How You could recommend NOT installing .NET 4.7 when DEFAULT .Net Version on Windows Server 2022 is 4.8
There is no way to fit this requirement.
.NET 4.8 is installed by default with (clean) operating system.
This answer has been deleted due to a violation of our Code of Conduct. The answer was manually reported or identified through automated detection before action was taken. Please refer to our Code of Conduct for more information.
Comments have been turned off. Learn more