Azure Database for PostgreSQL
An Azure managed PostgreSQL database service for app development and deployment.
This browser is no longer supported.
Upgrade to Microsoft Edge to take advantage of the latest features, security updates, and technical support.
On Azure Database for PostgreSQL Flexible Server (PostgreSQL 18, Burstable tier), an Entra user principal created with pgaadauth_create_principal('<user UPN>', false, true) is refused at login with:
FATAL: The specified role must be authenticated using Azure Multi-Factor Authentication.
The access token does contain mfa. What I've checked:
The documentation says "The isMfa flag tests the mfa claim in the Microsoft Entra ID token", which this token has.
Questions:
An Azure managed PostgreSQL database service for app development and deployment.