Adding a custom domain to API Mangement Service fails

Eric Mueller (dapi1) 0 Reputation points
2026-01-08T10:52:16.47+00:00

Hello everyone,

when trying to add a custom domain to our API Management Service, using a custom certificate (imported in a KeyVault), the custom domain disappears after a few seconds.

When checking the activity logs of the service, after some time the following error appears:

Unable to Update API service at this time. Please check resource group deployment logs for specific errors, correct them and try again

We also get the following information:

correlationId 6dade8a0-3a75-4135-a093-aedef917a35e and TimeStamp 1/7/2026 2:56:23 PM

Is there any way to get more information out of this error ?

My certificates settings in the service look like the following:

User's image

It is worth mentioning, that the certificate is valid until the end of this year and that the CNAME pointing to <service-name>.azure-api.net is configured and valid.

Azure API Management
Azure API Management

An Azure service that provides a hybrid, multi-cloud management platform for APIs.


1 answer

Sort by: Newest
  1. Siddhesh Desai 8,210 Reputation points Microsoft External Staff Moderator
    2026-01-08T12:05:43.0766667+00:00

    Hi @Eric Mueller (dapi1)

    Thank you for reaching out to Microsoft Q&A

    As per our discussion on teams the engineering team has provided below resolution to fix your issue:

    Customer TXT record has the wrong value; you need to modify it or delete it but make sure CNAME record is valid.

    The error is from App Service when they do the custom domain validation before adding, not from APIM. The link customer shared is for APIM free certificate feature and the Txt is required for apimuid.<custom domain>. But the error message complained about asuid.<custom domain>. Customer must try to configure the same domain for other App Service service before. So please follow my instructions before to correct Txt record. [Customer TXT record has the wrong value; they need to modify it or delete it but make sure CNAME record is valid.]

     

    Was this answer helpful?

    0 comments No comments

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.