Hi Henry.
Thank you for your answer.
The problem was resolved by using FSLogix.
Thank you for your cooperation.
This browser is no longer supported.
Upgrade to Microsoft Edge to take advantage of the latest features, security updates, and technical support.
Hello.
I am posting from Japan.
Please note that we use translation software, so some expressions may not be accurate.
We have built a remote desktop services deployment using Windows Server 2022 Standard.
If you create a collection in Windows 10 Enterprise LTSC 2021, when you log in with the corresponding user, the user profile disk is connected and a profile is created.
However, if you create a collection with Windows 11 Enterprise LTSC 2024 and log in with the corresponding user, the message "Can't sign in to your account. This issue can often be resolved by signing out of your account and signing back in. If you don't sign out now, any files or changes you make will be lost." will be displayed. (No matter how many times you sign out and log back in, the problem remains.)
Additionally, the server event log records the following:
"The Remote Desktop Virtualization Host could not attach the user profile disk to the virtual desktop for the user account with SID S-1-5-21-4288427863-2407394410-2288648904-1326.
Virtual Desktop Name: TEST-2
Hresult: 0x80078007"
"The Remote Desktop Virtualization Host failed to apply the user desktop for user account with SID S-1-5-21-4288427863-2407394410-2288648904-1326. A temporary profile was applied to this user. Please verify that your user profile disk settings are correct.
Virtual Desktop Name: TEST-2
Error: 0x1.0"
(Folder permissions do not seem to be an issue)
Please let me know how to solve this problem.
Hi Henry.
Thank you for your answer.
The problem was resolved by using FSLogix.
Thank you for your cooperation.
Hi tmsky, this is Henry. I’d like to share some thoughts on the issue. I appreciate your effort in translating, it helped me understand better.
The problem is that User Profile Disks (UPD) are old technology and are not fully compatible with Windows 11. The error code 0x80078007 indicates a failure to mount the virtual disk, which is a known issue with UPD on newer operating systems.
Quick Check (Before you change)
While it is certainly a UPD compatibility issue, you can quickly check permissions:
The official Microsoft solution is to stop using UPD and switch to FSLogix Profile Containers. FSLogix is modern, more reliable, faster, and fully supported on Windows 11. You can reference these steps:
When users log in, FSLogix will create a new profile container in the same location, and the login will succeed.
I hope this information is helpful.