Unable to update Azure Storage Account minimum TLS version: Error: Managed Service Identity (MSI) was not found for resource ''

Thomas Levesque 101 Reputation points
2025-01-30T08:36:01.42+00:00

Following the announcement about the retirement of TLS 1.0 and 1.1 support, I tried to update the minimum TLS version on one of my storage accounts to 1.2 (via the Azure Portal).

It failed with the following error:

Failed to update storage account '(redacted)'. Error: Managed Service Identity (MSI) was not found for resource ''.

As far as I can tell, there's nothing special about this storage account. Here are its main properties:

User's image

I have successfully updated all my other storage accounts, the error only occurs for this one.

I tried to update it via PowerShell, but it gave the same error.

Any idea what could be causing this and how to fix it?

Thanks

Azure Storage
Azure Storage

Globally unique resources that provide access to data management services and serve as the parent namespace for the services.


Answer accepted by question author
Anonymous
2025-02-07T11:05:48.6933333+00:00

Hi Thomas Levesque

Greetings & Welcome to Microsoft Q&A forum! Thanks for posting your query!

Posting as solution, After deleting the managed identity was able to resolve the issue.

Command:

(Get-AzStorageAccount -ResourceGroupName "<your-resource-group>" -Name "<your-storage-account>").Identity 
Set-AzStorageAccount -ResourceGroupName "<resource grp name>" -Name "<Storage account name>" -IdentityType None

Please do not forget to "Accept the answer” and “up-vote” wherever the information provided helps you, this can be beneficial to other community member

Was this answer helpful?

3 people found this answer helpful.
0 comments No comments

0 additional answers

Sort by: Oldest

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.