Using classic Outlook for Windows in business environments
I had this exact problem at a customer with Exchange Server On Premises.
It turned out that someone had created a Group in AD, that used the same e-mail as the Mailbox.
I only got an error, when I used Exchange ECP, to edit the secondary e-mail of the mailbox.
Then I got the error, that the e-mail ******@mymail.com was already in use, for the Group named "Group xxxxyyyyzzz"
I Deleted the group, and then error was gone.