Failed CIAM resource blocks resource-group deletion; external tenant inaccessible

Uralstech 20 Reputation points
2026-10-04T20:57:18.5433333+00:00

I cannot delete resource group <resource-group>. Its only remaining resource is:

Microsoft.AzureActiveDirectory/ciamDirectories/name1dom1.onmicrosoft.com

The resource has provisioningState: Failed.
Deletion returns 403 Forbidden: Only Global Administrators for this directory can manage its settings. An earlier attempt returned AADB2C95060: UserCountExceeded.
The associated external tenant is different from my main tenant. I believe it was created earlier and then I deleted the account maybe an entra account and I no longer remember which one it was.

I cannot complete the normal tenant-deletion prerequisites because the directory is inaccessible.

Azure Role-based access control
Azure Role-based access control

An Azure service that provides fine-grained access management for Azure resources, enabling you to grant users only the rights they need to perform their jobs.

0 comments No comments

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.