An Azure platform as a service offer that is used to deploy web and cloud applications.
Cloud Shell VNet Isolation fails with VnetClientNotSupported after reset and reconfiguration
Hi,
I can create and use Azure Cloud Shell from the portal without any config. However when I try to assign it to a existing private network I get the below error. I've spent a lot of time with Copilot trying resolve this but no result yet.
Sorry, your Cloud Shell failed to provision: {"code":"VnetClientNotSupported","message":"Your Cloud Shell virtual network (VNet) isolation settings were configured with a newer version that this client does not support. Please open Cloud Shell from the Azure Portal to continue."} Please refresh the page. If the issue persists, please follow the troubleshooting guide Cloud Shell Troubleshooting or file a ticket New support request.
Note, despite the error message, it is being opened from the Azure Portal. Things I've done/observed
- Microsoft.PowerPlatform registered
- Microsoft.Relay registered
- relay namespace recreated
- subnet recreated and assigned as Microsoft.ContainerInstance/containerGroups
- storage account attached (fails with a storage account and without)
- Cloud Shell user settings reset (multiple times)
Any help would be appreciated.