Eine leistungsstarke E-Mail-, Kalender- und Kollaborationsplattform, entwickelt von Microsoft für Unternehmenskommunikation und Datenmanagement.Verschiedene Themen, die nicht in bestimmte Kategorien passen.
Moin Katherine,
ja – ein defektes HTTPS-Binding, insbesondere auf 0.0.0.0:444, kann genau dieses Fehlerbild verursachen: OWA, ECP, EMS und die Outlook-Verbindungen fallen gleichzeitig aus. Aber bitte nicht einfach dasselbe Zertifikat auf beide Websites binden.
Der Sollzustand lautet:
| IIS-Site | Port | Zertifikat |
|---|---|---|
| Default Web Site | 443 | Öffentliches/produktives Exchange-Zertifikat mit Private Key |
| -------- | -------- | -------- |
| Default Web Site | 443 | Öffentliches/produktives Exchange-Zertifikat mit Private Key |
| Exchange Back End | 444 | Selbstsigniertes Zertifikat „Microsoft Exchange“ |
Nicht mit dem „Microsoft Exchange Server Auth Certificate“ verwechseln – das gehört nicht auf Port 444.
Zuerst prüfen:
Event 15021 beziehungsweise ein fehlendes/falsches Binding auf 0.0.0.0:444 wäre ein ziemlich eindeutiger Treffer. Microsoft beschreibt dieses Fehlerbild ausdrücklich bei fehlerhaften Exchange-Updates. Microsoft: Fix failed Exchange Server updates
Vor der Änderung kurz die IIS-Konfiguration sichern:
Dann:
- Das produktive Zertifikat über die EMS wieder IIS zuweisen:
- Im IIS unter Exchange Back End → Bindings → HTTPS/444 das gültige selbstsignierte Zertifikat „Microsoft Exchange“ auswählen. Diese manuelle Reparatur im IIS ist für Port 444 der von Microsoft dokumentierte Weg. Microsoft: Exchange-Backend-Zertifikat wiederherstellen
- Fehlt das selbstsignierte Zertifikat vollständig:
Die Rückfrage zum Überschreiben des standardmäßigen SMTP-Zertifikats mit Nein beantworten und das neue Zertifikat anschließend auf Port 444 binden.
Erst danach IIS kontrolliert neu starten:
Das ist einem blinden iisreset vorzuziehen, ändert am notwendigen kurzen Ausfall aber nichts. Bei mehreren Exchange-Servern beziehungsweise Loadbalancing unbedingt nur einen Server nach dem anderen bearbeiten.
Falls die Bindings korrekt sind, aber HTTP 500 erscheint, spricht das eher für ein unvollständig installiertes Exchange-SU. Dann das exakt passende .msp erneut aus einer als Administrator gestarteten Eingabeaufforderung installieren und anschließend den Server neu starten. Prüft außerdem C:\ExchangeSetupLogs\ServiceControl.log, falls Exchange-Dienste nach dem Update deaktiviert geblieben sind.
Nach dem Restore:
Danach den aktuellen Microsoft-Exchange Health Checker laufen lassen.Moin Katherine,
ja – ein defektes HTTPS-Binding, insbesondere auf 0.0.0.0:444, kann genau dieses Fehlerbild verursachen: OWA, ECP, EMS und die Outlook-Verbindungen fallen gleichzeitig aus. Aber bitte nicht einfach dasselbe Zertifikat auf beide Websites binden.
Der Sollzustand lautet:
| IIS-Site | Port | Zertifikat |
|---|---|---|
| Default Web Site | 443 | Öffentliches/produktives Exchange-Zertifikat mit Private Key |
| Exchange Back End | 444 | Selbstsigniertes Zertifikat „Microsoft Exchange“ |
Nicht mit dem „Microsoft Exchange Server Auth Certificate“ verwechseln – das gehört nicht auf Port 444.
Zuerst prüfen:
Event 15021 beziehungsweise ein fehlendes/falsches Binding auf 0.0.0.0:444 wäre ein ziemlich eindeutiger Treffer. Microsoft beschreibt dieses Fehlerbild ausdrücklich bei fehlerhaften Exchange-Updates. Microsoft: Fix failed Exchange Server updates
Vor der Änderung kurz die IIS-Konfiguration sichern:
Dann:
- Das produktive Zertifikat über die EMS wieder IIS zuweisen:
- Im IIS unter Exchange Back End → Bindings → HTTPS/444 das gültige selbstsignierte Zertifikat „Microsoft Exchange“ auswählen. Diese manuelle Reparatur im IIS ist für Port 444 der von Microsoft dokumentierte Weg. Microsoft: Exchange-Backend-Zertifikat wiederherstellen
- Fehlt das selbstsignierte Zertifikat vollständig:
Die Rückfrage zum Überschreiben des standardmäßigen SMTP-Zertifikats mit Nein beantworten und das neue Zertifikat anschließend auf Port 444 binden.
Erst danach IIS kontrolliert neu starten:
Das ist einem blinden iisreset vorzuziehen, ändert am notwendigen kurzen Ausfall aber nichts. Bei mehreren Exchange-Servern beziehungsweise Loadbalancing unbedingt nur einen Server nach dem anderen bearbeiten.
Falls die Bindings korrekt sind, aber HTTP 500 erscheint, spricht das eher für ein unvollständig installiertes Exchange-SU. Dann das exakt passende .msp erneut aus einer als Administrator gestarteten Eingabeaufforderung installieren und anschließend den Server neu starten. Prüft außerdem C:\ExchangeSetupLogs\ServiceControl.log, falls Exchange-Dienste nach dem Update deaktiviert geblieben sind.
Nach dem Restore:
Danach den aktuellen Microsoft-Exchange Health Checker laufen lassen.