Hello!
We're facing an issue with one of our Servers. It's a Windows Server 2022 Standard. Starting March/April 2024 we're unable to install any updates every month.
We've tried every solution there is, but the only temporary fix seems to be using DISM with an offline ISO file, using the /Source parameter. After doing this and a reboot, every update installs just fine - until next cycle of updates begins (the following month).
So far we've tried:
DISM /Online /Cleanup-Image /RestoreHealth - no changes
sfc /scannow - no changes
reset windows updates components - no changes
DISM /Online /Cleanup-Image /RestoreHealth /Source:PATHTOISO - works until the following month with new updates
CBS log:
InternalOpenPackage failed for Package_for_KB3025096~31bf3856ad364e35~amd64~~6.4.1.0 [HRESULT = 0x800f0805 - CBS_E_INVALID_PACKAGE]
2024-07-12 11:08:58, Info CBS Failed to internally open package. [HRESULT = 0x800f0805 - CBS_E_INVALID_PACKAGE]
2024-07-12 11:08:58, Info CBS Failed to create open package. [HRESULT = 0x800f0805 - CBS_E_INVALID_PACKAGE]
2024-07-12 11:08:58, Info CBS Failed to OpenPackage using worker session [HRESULT = 0x800f0805]
2024-07-12 11:08:58, Info CBS Session: 31118395_556423986 initialized by client WindowsUpdateAgent, external staging directory: (null), external registry directory: (null)
2024-07-12 11:08:58, Info CBS InternalOpenPackage failed for Package_for_KB3025096~31bf3856ad364e35~x86~~6.4.1.0 [HRESULT = 0x800f0805 - CBS_E_INVALID_PACKAGE]
2024-07-12 11:08:58, Info CBS Failed to internally open package. [HRESULT = 0x800f0805 - CBS_E_INVALID_PACKAGE]
2024-07-12 11:08:58, Info CBS Failed to create open package. [HRESULT = 0x800f0805 - CBS_E_INVALID_PACKAGE]
2024-07-12 11:08:58, Info CBS Failed to OpenPackage using worker session [HRESULT = 0x800f0805]
We tried installing the mentioned KB3025096 manually (which was released in 2014?! how is that even possible?), but it fails with error code 0x800b0101: "A required certificate is not within its validity period when verifying against the current system clock or the timestamp in the signed file."
Does anybody else have this issue or maybe knows how to fix it? We can't just install a new server like that, since it's it's the main app server from our customer.
Thank you!