Wie behebe ich eine beschädigte SQL Datenbank mit dem Fehlercode 7024?

BiancaJessen-7358 0 Zuverlässigkeitspunkte
2024-10-22T12:57:25.8033333+00:00

Können Sie mir helfen, den Dienst für diese Instanz wieder zum Laufen zu bringen oder muss der Server zurückgesetzt werden auf einen Backup-und Wiederherstellungspunkt?
Ich wollte ein SQL Server Update starten und nun startet der MSSQL Dienst nicht mehr. Und die Benutzer können Microsoft Dynamics NAV 2009R2 nicht wie gewohnt ausführen.

Vielen Dank im Voraus.

Ereignisprotokoll:
Der Dienst "SQL Server (Instanz1)" wurde mit dem folgenden dienstspezifischen Fehler beendet:
Das Objekt oder die Eigenschaft wurde nicht gefunden.
EreignisID: 7024
Schlüsselwort: Klassisch

Errorlog:

2024-10-14 12:24:02.65 spid19s Fehler: 17190, Schweregrad: 16, Status: 1. 14.10.2024 12:24:02.65 spid19s Die Initialisierung des FallBack-Zertifikats ist mit Fehlercode 15, Status 29 und Fehlernummer 0 fehlgeschlagen. 14.10.2024 12:24:02.66 spid19s Die SSL-Verschlüsselung konnte nicht initialisiert werden, da kein gültiges Zertifikat gefunden werden konnte und kein selbstsigniertes Zertifikat erstellt werden kann. 14.10.2024 12:24:02.66 spid19s Fehler: 17182, Schweregrad: 16, Status: 1. 14.10.2024 12:24:02.66 spid19s Die Initialisierung des TDSSNIClient ist mit Fehler 0x80092004, Statuscode 0x80 fehlgeschlagen. Grund: Die SSL-Unterstützung konnte nicht initialisiert werden. 2024-10-14 12:24:02.66 spid19s Fehler: 17182, Schweregrad: 16, Status: 1. 2024-10-14 12:24:02.66 spid19s TDSSNIClient-Initialisierung ist mit Fehler 0x80092004, Statuscode 0x1 fehlgeschlagen. Grund: Initialisierung ist mit einem Infrastrukturfehler fehlgeschlagen. Prüfen Sie auf vorherige Fehler. 2024-10-14 12:24:02.66 spid19s Fehler: 17826, Schweregrad: 18, Status: 3. 2024-10-14 12:24:02.66 spid19s Die Netzwerkbibliothek konnte aufgrund eines internen Fehlers in der Netzwerkbibliothek nicht gestartet werden. Um die Ursache zu ermitteln, überprüfen Sie die Fehler, die diesem Fehler unmittelbar vorausgehen, im Fehlerprotokoll. 14.10.2024 12:24:02.66 spid19s Fehler: 17120, Schweregrad: 16, Status: 1. 14.10.2024 12:24:02.66 spid19s SQL Server konnte den Thread FRunCommunicationsManager nicht starten. Überprüfen Sie das SQL Server-Fehlerprotokoll und das Fehlerprotokoll des Betriebssystems auf Informationen zu möglichen damit verbundenen Problemen.

Mit freundlichen Grüßen,

Bianca Jeßen

Windows für Unternehmen | Windows Server | Benutzerfreundlichkeit | PowerShell
Windows für Unternehmen | Windows Server | Benutzerfreundlichkeit | Andere
Community Center | Besprechen der F&A-Website | Erste Schritte mit F&A
SQL Server | Andere
SQL Server | Andere

Zusätzliche SQL Server-Funktionen und -Themen, die nicht von bestimmten Kategorien abgedeckt werden

0 Kommentare Keine Kommentare

1 Antwort

Sortieren nach: Am hilfreichsten
  1. Olaf Helper 47,621 Zuverlässigkeitspunkte
    2024-10-23T07:16:19.5133333+00:00

    War diese Antwort hilfreich?

    Eine Person fand diese Antwort hilfreich.
    0 Kommentare Keine Kommentare

Ihre Antwort

Antworten können von Fragestellenden als „Angenommen“ und von Moderierenden als „Empfohlen“ gekennzeichnet werden, wodurch Benutzende wissen, dass diese Antwort das Problem des Fragestellenden gelöst hat.